レンサバがパワーアップしたので、いろいろやってみたのだが


C言語中級編も6章に入ってから何故だかぐいっと難しくなり、なかなか日記に書けないでいます。そんな中、Redmineをインストールしていたサーバーがパワーアップしたようなので、ちょっといじってみました。

Apacheも2系になり、たしかOSもFreeBSDの9だったかに変わったので、案の定と言いますか、当然Redmineは起動しなくなっていました。当然というのもあれだけど、ググってみると、MongrelのバージョンとRubyのバージョンが何やらよろしくないという事が検索結果から導き出された。

てなわけで、以前から予定していた通り、Rubyを自前でインストールしましたのです。

これがデフォルトのRuby。

% ruby -v
ruby 1.8.7 (2012-10-12 patchlevel 371) [amd64-freebsd9]

んでソースからインストールしました結果こうなりました。

% ruby -v
ruby 2.1.1p76 (2014-02-24 revision 45161) [x86_64-freebsd9.1]

そしてちょっとアップデートしようかな~と。
最初は良かったかのように見えたのだけど・・・

% gem update
Updating installed gems
Updating actionmailer
Fetching: builder-3.1.4.gem (100%)
Successfully installed builder-3.1.4
Successfully installed activesupport-4.0.3
Fetching: actionpack-4.0.3.gem (100%)
Successfully installed actionpack-4.0.3
Fetching: actionmailer-4.0.3.gem (100%)
Successfully installed actionmailer-4.0.3
Parsing documentation for actionmailer-4.0.3
Installing ri documentation for actionmailer-4.0.3
Installing darkfish documentation for actionmailer-4.0.3

rc!だんだん雲行きが怪しくなってきました。

Updating coffee-rails
Fetching: minitest-5.3.0.gem (100%)
Successfully installed minitest-5.3.0
Fetching: tzinfo-1.1.0.gem (100%)
Successfully installed tzinfo-1.1.0
Fetching: activesupport-4.1.0.rc1.gem (100%)
Successfully installed activesupport-4.1.0.rc1
Fetching: actionview-4.1.0.rc1.gem (100%)
Successfully installed actionview-4.1.0.rc1
Fetching: actionpack-4.1.0.rc1.gem (100%)
Successfully installed actionpack-4.1.0.rc1
Fetching: railties-4.1.0.rc1.gem (100%)
Successfully installed railties-4.1.0.rc1
Fetching: coffee-rails-4.0.1.gem (100%)

もうどうにも止まらないようです。

Done installing documentation for psych after 2 seconds
Updating rails
Fetching: railties-4.0.3.gem (100%)
Successfully installed railties-4.0.3
Fetching: sprockets-rails-2.0.1.gem (100%)
Successfully installed sprockets-rails-2.0.1
Fetching: rails-4.0.3.gem (100%)
Successfully installed rails-4.0.3
Parsing documentation for rails-4.0.3
Installing ri documentation for rails-4.0.3

最終的にはこんな事になってしまいました。

% rails -v
Rails 4.1.0.rc1

ググってググってを繰り返していって、いろいろ繰り返していくうちに、検索結果が英語だけになったら、もう詰まりぎみですなあ。だけど多少はがんばって進めていたんだけども、英語のページですらとりあえず再インストールな。という結果が一番上に表示されてしまった。。

ま、仕方ないな。

 

んでも、またレンサバで最初からいろいろやってRailsを動かすのも、そこまでやる気もでないのでまたプログラムを書く日記になると思いまするー。

 

Similar Posts:


Leave a Reply

Your email address will not be published. Required fields are marked *